帮助

【百度地图API】您所使用的地图JS API版本过低,已不再维护,为保证地图基本功能 正常使用,请尽快升级到最新版地图JS API

2022-08-26

您所使用的地图JS API版本过低,已不再维护,为保证地图基本功能 正常使用,请尽快升级到最新版地图JS API


出现原因
最近有些使用百度API的网站网页还在使用1.0或者1.4版本的JS API文件,导致出现这样的错误,示范如下图:


如何修改



https://lbsyun.baidu.com/apiconsole/key#/home申请应用,会得到AK

 


复制上面的AK,然后复制下面的链接,在模板文件里找到js文件里修改,替换之前的链接

替换前:

<script type="text/javascript" src="http://api.map.baidu.com/getscript?v=1.4&ak=&services=&t=20180102095227"></script>

<script type="text/javascript" src="http://api.map.baidu.com/getscript?v=1.0&ak=&services=&t=20180102095227"></script>


替换后的链接如下:

<script type="text/javascript" src="https://api.map.baidu.com/api?v=3.0&ak=这里改为你复制的AK密钥"></script>

或者

<script type="text/javascript" src="//api.map.baidu.com/api?v=3.0&ak=这里改为你复制的AK密钥"></script>


如何找到百度地图调用API的js文件:

网站模板目录里找到地图所属的模板文件(显示地图的模板文件),在模板文件里找到百度地图调用API的js文件,这个js的文件名可能每个模板都不一样,需要自己打开查看。

例:

找到文件后,打开这个文件修改里面的API代码。

例:




重新刷新页面应该就更新正常了。



如需定制请联系易优客服咨询:800182392 点击咨询
QQ在线咨询